android:Unsupported major.minor version 52.0

错误描述

使用android studio项目编译过程报如下错误:

java.lang.UnsupportedClassVersionError: com/android/build/gradle/AppPlugin : Unsupported major.minor version 52.0

错误原因

gradle2.2必须使用JDK8及以上版本。

解决方式

  1. 将电脑jdk版本改为1.8
  2. 将gradle版本降为2.2以下,但是注意as2.2必须要相对应版本以上的gradle(2.2)。