Android Rxjava2

1.Android Rxjava2的配置:

Android Studio中的配置:
在Moudle的Gradle中添加

compile ‘io.reactivex.rxjava2:rxandroid:2.0.1’compile "io.reactivex.rxjava2:rxjava:2.0.8"

Android Rxjava2通常配合Lambda表达式一块使用:
需要JDk版本1.8版本:
配置:

在项目的根目录的Gradle中配置:buildscript { dependencies { classpath ‘com.android.tools.build:gradle:2.2.0’ //引入lambda classpath ‘me.tatarka:gradle-retrolambda:3.2.5’ }}

在Moudle的gradle中配置:

apply plugin: ‘me.tatarka.retrolambda’Android下添加的: android { compileOptions { sourceCompatibility JavaVersion.VERSION_1_8 targetCompatibility JavaVersion.VERSION_1_8 }}