老的retropie如何兼容到树莓派3B+

老的retropie如何兼容到树莓派3B+

老版本为什么不支持3B+的原因 :新版的板子只支持基于raspbian stretch系统的retropie。所以简单的升级内核没有作用。但是在retropie4.4之前的系统是基于jessie的 所以要把系统升级到stretch。

进入终端

1、把/etc/apt/sources.list 和/etc/apt/sources.list.d/raspi.list 里面的 “jessie” 换成 “stretch” .

2、sudo ~/RetroPie-Setup/retropie_setup.sh 然后 “Update Retropie-Setup script”

3、sudo shutdown -r now或者sudo reboot随便

4、sudo apt-get update 无视报错

5、sudo apt-get upgrade 如果有问题sudo apt-get upgrade –fix-missing

6、sudo apt-get dist-upgrade如果有问题sudo apt-get dist-upgrade –fix-missing

7、sudo apt-get -y autoremove –purge &

&

sudo apt-get -y autoclean

8、sudo shutdown -r now或者sudo reboot随便

9、sudo ~/RetroPie-Setup/retropie_setup.sh选第一项回车 install

10.重启之后如果遇到缺少libboost_date_time.so.1.55.0 sudo ~/RetroPie-Setup/retropie_setup.sh进去安装emulation 重启就好了

原文始发于:老的retropie如何兼容到树莓派3B+

|

发表评论